Yachtworld.com problem?

pgadd

Member I
I’ve been having problems with yachtworld. i can access the site thru Sean’s link of the top 3 sites, but when I try to look at any particular Ericson, I get a “bad request” message. And if I try to just type yachtworld.com in as a url, I get the same message. Is anybody else having problems with yachtworld, or did something happen to my machine?
 

Sean Engle

Your Friendly Administrator
Administrator
Founder
Huh. I'll replace the link with an updated one...perhaps they changed something in their structure that is causing the lag. When I did it manually (as mentioned above) it came right up for me also.....

Let me know if it's still not working for you...

//sse
 

Loren Beach

O34 - Portland, OR
Senior Moderator
Blogs Author
Strictly FWIW, I have seen complaints on other sailing forums about the whole Yacht World search engine for the last six months at least. I have tried it and they have made some major changes in how parameters are set up.
Perhaps that affected our link.
That said, I tried our site link tonight and it worked.
There are... more pop up ads than there used to be. :(

This site remains a Viking Haven on the internet !!
 

Christian Williams

E381 - Los Angeles
Moderator
Blogs Author
For many years I've used an ad blocker. Currently (for Chrome browser) it is uBlock Origin ( https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm?hl=en )

I see no ads on the Internet. Zero. No popups. I see no ads on YouTube. Zero. Or Yachtworld or any other site.

Occasionally I am asked to turn it off. If I try to read a Forbes magazine article, for example, a message says: you must turn off your ad blocker to continue.. Sometimes I do, just for that page. Most of the time I just move on. I hate ads.

What soul did I sell to ad-blocker extensions? I don;t know. In 10 years I've never had a malware issue, and ad blockers are widely used on home computers.
 

pgadd

Member I
Using Sean’s link, I can get to yachtworld, but if I try to look at a boat, it craps out on me. And just trying from the url won’t even get me to yachtworld. The problem must be on my end. Thanks for your help! I guess I might need to make an appt at the genius bar. ☹
 

Sean Engle

Your Friendly Administrator
Administrator
Founder
Using Sean’s link, I can get to yachtworld, but if I try to look at a boat, it craps out on me. And just trying from the url won’t even get me to yachtworld. The problem must be on my end. Thanks for your help! I guess I might need to make an appt at the genius bar. ☹
Huh.... I checked it on mine and it works. You might try clearing out your cache (delete your history) in your browser, then start a new session. You should do this occasionally anyhow....
 

steven

Member III
It could be the browser and browser version. There are major problems on some web sites due to industry changes in supported software. If that is the case here, some browsers might work while others might not. If you have another browser you could try that.
 
Top